Software Upgrades Aren't Always Better

Amen to Stop! An IT Spending Manifesto! When my daughter was getting into AOL instant messaging (AIM) and using all the cool add-ons, I looked for more as it’s a great way to learn about extending applications. While doing research, I learned that if you wanted to use AIM themes, you don’t want to upgrade to AIM 5.9. A post at MyThemes suggests sticking with or downgrading to 5.5. MyTheme shows what steps to take, should you prefer to stick with 5.9. The post also shows where to download 5.5 and how to downgrade back to it. Furthermore, 5.9 was bloated. Think it took a while for AIM to completely load in 5.5? 5.9 is worse.

Many people, Paul included, didn’t upgrade WinAmp past version 2.8 because he didn’t like version 3.0’s playlist and it kept crashing. Then, he got a pop up that an upgrade was available. He figured he’d try it as it couldn’t hurt and he still had 2.81’s install. He liked the new interface and themes on version 5.0, so he stuck with it. That’s three versions later.

[Continue reading Software Upgrades Aren't Always Better]