Samba Printer DoS Vulnerability

“A vulnerability has been reported in Samba, which can be exploited by malicious people to cause a DoS (Denial of Service).

The vulnerability is caused due to an error within the handling of client printer change notification requests. This can be exploited to crash smbd by sending a “FindNextPrintChangeNotify()” request without first sending a “FindFirstPrintChangeNotify()” request.

The issue can reportedly be triggered by Windows XP SP2 clients.

Solution: Update to version 2.2.11.”