Microsoft Windows Security Bulletin Summary for April 2004

Critical Security Bulletins
MS04-011 Security Update for Microsoft Windows (835732)
MS04-012 Cumulative Update for Microsoft RPC/DCOM (828741)
Affected software is any NT based Windows — NT 4 SP6a Workstation and Server, Windows 2000 Professional and Server, Windows XP Home and Professional, and Windows Server 2003.
MS04-013 Cumulative Security Update for Outlook Express (837009)
Affects all versions of Windows starting with Windows 98 – and if you’re still using Windows 95 you really should get a new computer – or switch to Linux.
Important Security Bulletins
MS04-014 Microsoft Jet Database Engine Vulnerability (837001)
Affects Windows 2000 and newer – all versions. Also affects all Windows NT 4.0 SP6a versions with the Jet Database Engine version 4.0 installed – which comes with Office, Access, Visual Studio or many other MS applications. If Msjet40.dll is on your computer and is lower than version 4.0.8618.0 (check the Properties of the file), you need this update.